WordPress3.2 will use the new jquery package, part of the existing theme effects will be forced to modify the code

wordpress3.2 will use the new jquery package, part of the existing theme effects will be forced to modify the code

WordPress team has decided to abandon the old jQuery 1.4.4, and using the new jQuery 1.6.1. JQuery 1.6.1 is faster, wordpress development team make efforts to make wordpress 3.2 development faster and lighter.

However, this improvement makes some of wordpress template which use the jQuery effects invalid, because in the new version, the selector syntax changes, such as the previous $(‘input [name = submit]’), will fail, In the new version, the correct syntax is: $(‘input [name = “submit “]’); In addition, such as’ selected’, ‘checked’, ‘disabled’ will also be invalid, in the new version, .prop() will replace .Attr()…

Go to the official website to read all of the new JQuery changes.